Last update on .

Image of dental software laptop

As of August 31, 2018, DentiMax versions 2006, 2008, and 2011 will no longer be supported. What this means for your practice is while support will be available to help with very basic “how to” questions, we will no longer troubleshoot error messages or functionality issues related to these versions.

In such cases, we recommend purchasing an upgrade to the most current version of DentiMax.

Types of questions we will address for ‘06/’08/’11 customers:

How do I edit a scheduled appointment?

How do I batch print claims?

Types of questions we will not address for ‘06/’08/’11 customers:

I’m getting an error message when I try to send claims. What is causing it?

My report totals are wrong. Would you please help me determine why?

What happens to your current support contract when your version of DentiMax is no longer supported?

If you have a current monthly or annual support contract and choose to upgrade to the newest version of DentiMax, you support contract will transfer to the new version.

If you have a current annual support contract and choose not to upgrade to the newest version of DentiMax, your contract will cover only basic “how to” questions, as in the examples above. You may also choose to transfer the term of your contract to training hours with one of our dedicated trainers, or you may decide you’d like to apply the remaining balance of your support contract toward your upgrade.



Pingbacks

Pingbacks are closed.